this post was submitted on 18 Jan 2024
740 points (98.6% liked)

Programmer Humor

19187 readers
1393 users here now

Welcome to Programmer Humor!

This is a place where you can post jokes, memes, humor, etc. related to programming!

For sharing awful code theres also Programming Horror.

Rules

founded 1 year ago
MODERATORS
 
top 50 comments
sorted by: hot top controversial new old
[–] 0x0@lemmy.dbzer0.com 203 points 8 months ago (8 children)

I propose a new, more threatening kind of control flow.

do {
  /* something */
} or else {
  /* you don't want to find out */
}
[–] gex@lemmy.world 58 points 8 months ago (6 children)

Some C++ style guides suggest the following naming convention for functions that crash on any error

OpenFileOrDie()
[–] xmunk@sh.itjust.works 26 points 8 months ago (4 children)

PHP has the always wonderful (and perfectly functional) syntax of

logUserIn() or die();

load more comments (4 replies)
[–] Kissaki@programming.dev 10 points 8 months ago (1 children)

Personally, I like to call catched exception variables up, so for a rethrow I can throw up;.

load more comments (1 replies)
load more comments (4 replies)
[–] Strawberry@lemmy.blahaj.zone 41 points 8 months ago

this is just a menacing try/catch!

[–] moody@lemmings.world 22 points 8 months ago

It_would_be_a_shame_if(condition)

load more comments (5 replies)
[–] OpenStars@startrek.website 103 points 8 months ago (3 children)

Please God let this be a humorous post that somehow does not also find a way to manage to come true...

[–] jtk@lemmy.sdf.org 86 points 8 months ago* (last edited 8 months ago) (2 children)

I would have bought it if they said ifnot instead, it's the same number of characters and wouldn't require a major parser overhaul to support keywords with a ' in the name.

[–] pupbiru@aussie.zone 43 points 8 months ago (1 children)

i mean, “unless” tends to be the usual term for an “if not” keyword in languages that implement such a thing

[–] Fal@yiffit.net 20 points 8 months ago (4 children)

Which is awful and incredibly confusing. I hate ruby

load more comments (4 replies)
[–] OpenStars@startrek.website 13 points 8 months ago (2 children)

Yeah, to be clear, I don't like it, I don't like it one bit:-P.

load more comments (2 replies)
load more comments (2 replies)
[–] bappity@lemmy.world 98 points 8 months ago* (last edited 8 months ago) (1 children)
[–] runner_g@lemmy.blahaj.zone 45 points 8 months ago* (last edited 8 months ago)

nocap(frfr){

}

[–] MagicShel@programming.dev 75 points 8 months ago (4 children)

Reduce exclamation marks!? Great Scott!!!!! Is there a shortage of punctuation in the future!?

[–] KairuByte@lemmy.dbzer0.com 21 points 8 months ago

You could have saved two, all you had to do was use the interrobang. You’re a monster.

[–] jaybone@lemmy.world 13 points 8 months ago
[–] SubArcticTundra@lemmy.ml 12 points 8 months ago

All known deposits were depleted

load more comments (1 replies)
[–] ohlaph@lemmy.world 53 points 8 months ago (3 children)
aint (something) {
    somethingElse()
}
load more comments (3 replies)
[–] lung@lemmy.world 40 points 8 months ago (1 children)
[–] Deconceptualist@lemm.ee 40 points 8 months ago (1 children)

I believe that resolves the same as

ain't!(!untrue)

[–] rimjob_rainer@discuss.tchncs.de 38 points 8 months ago* (last edited 8 months ago) (3 children)

Why not just ifnot? Same count of characters but an o instead of a possibly problematic single quote.

[–] Ookami38@sh.itjust.works 19 points 8 months ago

I think it's just capitalizing on a trend to add n't to otherwise noy contractions, to make them into contractions. Contractionn'ts, if you will

[–] Ferk@kbin.social 17 points 8 months ago* (last edited 8 months ago)

Yes... how is "reducing exclamation marks" a good thing when you do it by adding a ' (not to be confused with , ´,or’` ..which are all different characters).

Does this rely on the assumption that everyone uses a US QWERTY keyboard where ! happens to be slightly more inconvenient than typing '?

[–] KmlSlmk64@lemmy.world 14 points 8 months ago (2 children)

If someone really wanted to add it, probably the best would be to use unless

load more comments (2 replies)
[–] xmunk@sh.itjust.works 36 points 8 months ago (2 children)

Still not as good as whence

[–] fartsparkles@sh.itjust.works 14 points 8 months ago (4 children)

Is this a reference to something because I’d love to read it if you have a time to share.

load more comments (4 replies)
load more comments (1 replies)
[–] xia@lemmy.sdf.org 31 points 8 months ago (3 children)

"Help's with readability"? You know what else helps? Not using contractions and introducing an unbalanced single quote.

[–] bdonvr@thelemmy.club 41 points 8 months ago (2 children)

If they'd'nt've done that, it'd've been better. Agreed.

load more comments (2 replies)
load more comments (2 replies)
[–] janabuggs@beehaw.org 29 points 8 months ago

I'm struggling to understand if this is true or ifn't true

[–] csm10495@sh.itjust.works 28 points 8 months ago

Imagine the regex needed to highlight code with that extra single quote.

[–] olafurp@lemmy.world 25 points 8 months ago (7 children)

I'd take a not or "if not" operator tbh.

load more comments (7 replies)
[–] taanegl@beehaw.org 24 points 8 months ago (1 children)

I'm just hoping this paves the way to code with Southern dialect

iffun is == true
iffun ain't == false
[–] timetravel@lemmings.world 21 points 8 months ago (1 children)

May I introduce you to the joys of #define and creating your own horrible sub language

load more comments (1 replies)
[–] muntedcrocodile@lemmy.world 17 points 8 months ago* (last edited 8 months ago) (1 children)

With ahit like that its not microsoft java its now microsoft javascript

load more comments (1 replies)
[–] Thcdenton@lemmy.world 17 points 8 months ago (1 children)
load more comments (1 replies)
[–] jtk@lemmy.sdf.org 16 points 8 months ago* (last edited 8 months ago) (2 children)
ifn't (myNum don't= 3 && myStr ain'tnull'rblankish)
[–] felbane@lemmy.world 14 points 8 months ago (1 children)

Please remain calm, we are sending paramedics to your location.

load more comments (1 replies)
load more comments (1 replies)
[–] AlmightySnoo@lemmy.world 12 points 8 months ago* (last edited 8 months ago)

reminds me of #ifndef instead of #if !defined(...)

[–] vlad76@lemmy.sdf.org 10 points 8 months ago (4 children)
[–] NekkoDroid@programming.dev 51 points 8 months ago (2 children)
[–] SpaceNoodle@lemmy.world 19 points 8 months ago (2 children)
load more comments (2 replies)
load more comments (1 replies)
load more comments (3 replies)
load more comments
view more: next ›