this post was submitted on 18 Jan 2024
740 points (98.6% liked)

Programmer Humor

19213 readers
1318 users here now

Welcome to Programmer Humor!

This is a place where you can post jokes, memes, humor, etc. related to programming!

For sharing awful code theres also Programming Horror.

Rules

founded 1 year ago
MODERATORS
 
you are viewing a single comment's thread
view the rest of the comments
[–] 0x0@lemmy.dbzer0.com 203 points 8 months ago (19 children)

I propose a new, more threatening kind of control flow.

do {
  /* something */
} or else {
  /* you don't want to find out */
}
[–] gex@lemmy.world 58 points 8 months ago (11 children)

Some C++ style guides suggest the following naming convention for functions that crash on any error

OpenFileOrDie()
[–] Vorthas@programming.dev 4 points 8 months ago

One of the modules in a project I'm working on is called VulkanOrDie which always makes me crack up when I see it in the compilation messages.

load more comments (10 replies)
load more comments (17 replies)