this post was submitted on 29 Apr 2024
120 points (96.2% liked)
Programming
17394 readers
183 users here now
Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!
Cross posting is strongly encouraged in the instance. If you feel your post or another person's post makes sense in another community cross post into it.
Hope you enjoy the instance!
Rules
Rules
- Follow the programming.dev instance rules
- Keep content related to programming in some way
- If you're posting long videos try to add in some form of tldr for those who don't want to watch videos
Wormhole
Follow the wormhole through a path of communities !webdev@programming.dev
founded 1 year ago
MODERATORS
you are viewing a single comment's thread
view the rest of the comments
view the rest of the comments
I was expecting something more profound. Isn't this just the concept of using variables to keep code readable? Not a new concept and likely one most devs learn early on.
I've had at least one code reviewer ask me to put all the logic in the
if ...
line rather than use a variable or two in order to "simplify code by reducing the number of variables."At the very least, this article helped me confirm my own bias of "that guy is a moron" and I can send this article to him the next time he reviews my code.
Yes, you need to push back on those people. They're the type that get high on code golf and end up writing unmaintainable one-liners measured in kilobytes for fun.
I review a ton of code and have a bunch reviewed in turn. I don't remember that last time I've had this come up. Either direction really. I guess I'm lucky. We just split naturally in similar places.
Well it actually depends.
Does it make the code more readable? Like you have several if statements using the same things (and/or else if)? Yeah then it's probably good.
If you have an if (work.lengt() == 0 && stacked_work.length() == 0) and that's it, probably not. Depending of whats happining then of course.
Be creative guys! But also dont be too creative :-) Think about the poor coder doing something with all that in a year or two, let's make his life less miserable (It's probably you, too).
"it actually depends"
Yes, it depends. But in this scenario we're not discussing if statements with one or two conditions. We're exclusively discussing multiple complicated conditions. :)
Well thei it is probably almost always good to clear things up :-) !
I guess this is go, and I don't know what the scoping is. In C++ I also suggest putting as much in the if as possible, because it limits the scope of the variables.
This is "Testing on the Toilet" which are short flyers that are posted in bathrooms at Google. They aren't typically meant to be particularly profound, just to remind people of common code patterns that can be written more clearly or other reminders that are good to keep in mind.