dialog_file_open_dialog I prefer big.LITTLE cpus
Programmer Humor
Welcome to Programmer Humor!
This is a place where you can post jokes, memes, humor, etc. related to programming!
For sharing awful code theres also Programming Horror.
Rules
- Keep content in english
- No advertisements
- Posts must be related to programming or programmer topics
I don't know and that's the problem :(
I keep asking myself what to choose, only for changing it a day after cursing myself to choose a stupid name.
Big endiant is great for intellisense to quickly browse possibilities, since it groups it all in the same place. But that's also a detriment when you know what you want. You can start typing without the prefix but you'll have to go through the better suggestions of intellisense first.
Little endiant is the same thing, but in reverse. Great when needed, but bad for browsing.
Although I do have some fix I'm starting to use. But it's not applicable everywhere, and not in every language.
What I do is use module as prefix. Instead of dialogue_file_open
, I create a file_open
in the dialogue
module, allowing either directly calling file_open
, or dialogue::file_open
. Using intellisense on the module allow for easy browsing too!
Although in OP's post I'd rather have file_open_dialogue
as it convey the more significant meaning, being to open a file, first. Then "dialogue" is just the flavour on top
Big endiant is great for intellisense to quickly browse possibilities, since it groups it all in the same place.
If only someone would train a program… we could call it a Large Language Model… to knowingly group the names together so we wouldn’t have to choose between human-readable format or dB format.
Guess that will never happen because instead we’re stuck using “AI’s” to inflate stock prices instead. /s
I remember seeing a proposed language that would allow each programmer to choose what name to use for each item. Don’t like ‘open_file’? Choose to see it as ‘file_open’ every time you review the file in the future.
While we battle with each other endlessly, we keep forgetting that the computer doesn’t care.
For me it's simple.
Pseudo-OOP in C which takes dialog* as a forst argument? dialog_open_file
Otherwise - make it human readable
Create a file handler class to avoid the issue
FileDialogFactory
Eww, that’s OOP
Meh, a class is just a struct
of function pointers.
Romance language word order noun_descriptor is the right way.
in general, adjectives and verbs after nouns because it's more organized/easier to search/filter. as god intended.
I know I'm late to this but here's my (probably insane?) take. We use Subject-Verb-Object in English right? So, hear me out:
dialog_create_tab(...)
dialog_open_file(...)
dialog_close_file(...)
We just call those Smurf names.
As a rule of thumb, I always put action verbs at the end of method names